1 (edited by yjafar 11-09-2014 19:18:19)

Topic: Required PHP modules

Hi,

I'm running Nibbleblog on FreeBSD (nginx) PHP55.

I'm posting this in case anyone else comes across the cryptic message relating to 'Nibbleblog security error - Failed to load $DB_SETTINGS'

I think the installation help/ prerequisite check should be updated as 4 additional modules are required, since FreeBSD installs without extensions:

I had to compile the following modules:

As well as the required,
PHP module - DOM
PHP module - SimpleXML
PHP module - GD

You will also require

PHP module - xml
PHP module - filter
PHP module - xmlwriter
PHP module - xmlreader

-- also version 4.0.3 + markdown states version 4.0.2 in the footer, not sure if this is just the version of the actual code base. The vanilla nibbleblog 4.0.3 correctly reads 4.0.3.

Would really love both Markdown and WYSIWYG featuring in the same release, I'd imagine it would make releasing a single version much easier to manage then two separate ones.

Re: Required PHP modules

How did you discover that those were also required?