Topic: Atom Feed + htaccess

It appears as though everything is working correctly except for Friendly URLs and the feed portion of the .htaccess file. I don't see anything wrong, but it doesn't show the feed.php page, but the 404.

Our site is http://scripts.westervillelibrary.org/director

Here is the htaccess file

# Disable directory browsing
Options -Indexes

# Disable Magic Quotes
<IfModule mod_php5.c>
php_flag magic_quotes_gpc off
</IfModule>

# Secure .xml files
<FilesMatch ".(xml)$">
Order Allow,Deny
Deny from all
</FilesMatch>

# Secure shadow.php
<Files shadow.php>
order allow,deny
deny from all
</Files>

# Secure keys.php
<Files keys.php>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /director/index.php?controller=page&action=404

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /director/

RewriteRule ^category/([^/]+)/page-([0-9]+)$ index.php?controller=blog&action=view&category=$1&number=$2 [L]
RewriteRule ^category/([^/]+)/$ index.php?controller=blog&action=view&category=$1&number=0 [L]
RewriteRule ^tag/([^/]+)/page-([0-9]+)$ index.php?controller=blog&action=view&tag=$1&number=$2 [L]
RewriteRule ^tag/([^/]+)/$ index.php?controller=blog&action=view&tag=$1&number=0 [L]
RewriteRule ^page-([0-9]+)$ index.php?controller=blog&action=view&number=$1 [L]
RewriteRule ^post/([^/]+)/$ index.php?controller=post&action=view&post=$1 [L]
RewriteRule ^post-([0-9]+)/(.*)$ index.php?controller=post&action=view&id_post=$1 [L]
RewriteRule ^page/([^/]+)/$ index.php?controller=page&action=view&page=$1 [L]
RewriteRule ^feed/$ feed.php [L]
RewriteRule ^([^/]+)/$ index.php?controller=page&action=$1 [L]
</IfModule>

Any suggestions on what I need to do to get this to work?

Thanks,

Dave

Re: Atom Feed + htaccess

Hi Dave,

Did you check if feed.php exists in your server?

English isn't my native language. Sorry for any mistakes you may find.

Re: Atom Feed + htaccess

Hi Luigi.

Sorry for not including this, but if I add the php extension it displays correctly. I think it is some type of htacess issue.

Dave

Re: Atom Feed + htaccess

Sorry I can't help you more. I don't know what could be wrong. neutral

Maybe you should try disabling friendly urls, erasing the content of your .htaccess file and then enable againg friendly urls and recreating the .htaccess file.

Regards

English isn't my native language. Sorry for any mistakes you may find.

Re: Atom Feed + htaccess

Hello,
The problem is in the .htaccess rule that generate Nibbleblog.
The code is missing the letter "s" it's "feeds" instead of "feed"

RewriteRule ^feeds/$ feed.php [L]